PHP 5.5.36 is available

The XSLTProcessor class

(PHP 5, PHP 7)

简介

类摘要

XSLTProcessor {
/* 方法 */
string getParameter ( string $namespaceURI , string $localName )
public int XsltProcessor::getSecurityPrefs ( void )
bool hasExsltSupport ( void )
public bool importStylesheet ( object $stylesheet )
void registerPHPFunctions ([ mixed $restrict ] )
bool removeParameter ( string $namespaceURI , string $localName )
bool setParameter ( string $namespace , string $name , string $value )
bool setProfiling ( string $filename )
public int XsltProcessor::setSecurityPrefs ( int $securityPrefs )
DOMDocument transformToDoc ( DOMNode $doc )
int transformToURI ( DOMDocument $doc , string $uri )
string transformToXML ( object $doc )
}

Table of Contents

add a note add a note

User Contributed Notes 2 notes

up
1
flavius
6 months ago
It requires PHP5 XSL extension. On linux:

sudo apt-get install php5-xsl
up
0
tschallacka
2 months ago
uncomment extension=php_xsl.dll on windows to activate it in your php.ini. Then restart your webserver to refresh php.
To Top