PHP 8.2.0 Beta 3 available for testing

Требования к установке

Для PHP требуется как минимум Windows 2008/Vista. 32-Bit или 64-bit (AKA X86 или X64. PHP не работает на Windows RT/WOA/ARM). Начиная с PHP 7.2.0, Windows 2008 и Vista больше не поддерживаются.

PHP требует наличия Visual C runtime(CRT). Многие приложения требуют, чтобы это уже было установлено.

Распространяемый Microsoft Visual C ++ для Visual Studio 2019 подходит для всех этих версий PHP, смотрите » https://visualstudio.microsoft.com/downloads/.

Вы должны скачать x86 CRT для сборки PHP x86 и x64 CRT для сборки PHP x64.

Если CRT уже установлен, установщик скажет вам об этом и ничего не будет устанавливать.

Инсталятор CRT поддерживает опции командной строки /quiet и /norestart, вы можете использовать их при запуске скрипта.

add a note

User Contributed Notes 1 note

up
-17
v4ri4bl3 at gmail dot com
2 months ago
Install using Windows Terminal (or PowerShell):

  > winget install Microsoft.VC++2015-2022Redist-x64

Other version ids:
- Microsoft.VC++2015-2022Redist-x86
- Microsoft.VC++2019Redist-arm64
To Top