Installation

To enable SOAP support, configure PHP with --enable-soap .

add a note add a note

User Contributed Notes 6 notes

up
-2
dbagnara
2 years ago
for Ubuntu 16.04 LTS
sudo apt-get install php7.0-soap
sudo systemctl restart apache2.service
up
-6
slawkens
5 months ago
for latest MacOS with brew, where Homebrew/PHP is deprecated:

brew install php@7.2-soap

(change 7.2 to your version)
up
-15
wally at soggysoftware dot co dot uk
1 year ago
If you're using official PHP packages shipped with CentOS or RedHat version 6 or 7:

# yum install php-soap

(Restart Apache/nginx too if appropriate.)
up
-12
cdvillagra
1 year ago
If you have not yet updated the OS and also the PHP version

for Ubuntu 14.04 LTS
sudo apt-get install php5.6-soap
sudo service apache2 restart
up
-18
digimix.co
1 year ago
On PHP7.1 Ubuntu 16.04 LTS:
$ sudo apt-get install php7.1-soap
$ sudo service php7.1-fpm reload
up
-20
c at cinqs dot net
1 year ago
If you received a

    E: Couldn't find any package by regex 'php7.1-soap'

when using docker php:apache image

try

    apt-get install php-soap

instead
To Top