PHPKonf İstanbul PHP Conference 2015

Installation

PHP 5.2.0 et supérieur

Systèmes Linux

Afin d'utiliser ces fonctions, vous devez compiler PHP avec le support Zip en utilisant l'option de configuration --enable-zip .

Depuis PHP 5.6.0, l'option de configuration --with-libzip=DIR a été ajoutée pour utiliser une installation existante de libzip. La version 0.11 de libzip est nécessaire, mais nous vous recommandons la version 0.11.2 ou supérieure.

Windows

Les utilisateurs de Windows doivent activer la bibliothèque php_zip.dll dans le php.ini afin d'utiliser ces fonctions.

Installation via PECL

Des informations sur l'installation de ces extensions PECL peuvent être trouvées dans le chapitre du manuel intitulé Installation des extensions PECL. D'autres informations comme les notes sur les nouvelles versions, les téléchargements, les sources des fichiers, les informations concernant les mainteneurs ainsi qu'un CHANGELOG, peuvent être trouvées ici : » http://pecl.php.net/package/zip.

add a note add a note

User Contributed Notes 3 notes

up
1
phpdev at ehrhardt dot nl
1 year ago
+1 for Tom's comment. I just requested to remove php_zip.dll from the example php.ini's:
https://github.com/php/php-src/pull/404

Please update the documentation as well.
up
-7
alvaro at demogracia dot com
4 years ago
Docs only mention PHP/4 and PHP/5.2.0 and later. For PHP/5.0 and PHP/5.1 you can simply install the PECL extension; despite being an external download, it's basically the same library.
up
-8
tom at tomwardrop dot com
5 years ago
To expand on the previous comment. This extension now seems to be built-in to PHP 5.3.0 (at least for windows).
To Top