PHP 8.0.0 Released!

Требования

Для pthreads необходима потокобезопасная сборка PHP, т.е. ZTS (Zend Thread Safety). Сделать это можно указав при компиляции ключ --enable-maintainer-zts, либо --enable-zts для Windows.

Предостережение

После компиляции потокобезопасность нельзя включить - это исключительно опция, устанавливаемая на этапе компиляции.

pthreads можно собрать везде, где присутствуют заголовочные файлы Posix Threads (pthread.h) и потокобезопасная сборка PHP, включая Windows (используя проект pthread-w32 из redhat).

add a note add a note

User Contributed Notes

There are no user contributed notes for this page.
To Top