Voraussetzungen für die Installation

Für PHP wird mindestens Windows 2008/Vista benötigt, entweder 32-Bit oder 64-Bit (auch bekannt als X86 oder X64; PHP läuft nicht auf Windows RT/WOA/ARM). Windows 2008 und Vista werden seit PHP 7.2.0 nicht mehr unterstützt.

PHP benötigt die Visual C-Laufzeitumgebung (C RunTime, CRT). Da diese für viele Anwendungen erforderlich ist, ist sie möglicherweise bereits installiert.

Die Microsoft Visual C++ Redistributable für Visual Studio 2019 ist für alle genannten PHP-Versionen geeignet, siehe » https://visualstudio.microsoft.com/downloads/.

Sie MÜSSEN für PHP-x86-Builds die x86-CRT herunterladen und für PHP-x64-Builds die x64-CRT.

Wenn CRT bereits installiert ist, wird das Installationsprogramm Sie darauf hinweisen und nichts ändern.

Das CRT-Installationsprogramm unterstützt die Befehlszeilenoptionen /quiet und /norestart, sodass Sie diese beim Ausführen als Skript verwenden können.

add a note

User Contributed Notes 1 note

up
-29
v4ri4bl3 at gmail dot com
5 months ago
Install using Windows Terminal (or PowerShell):

  > winget install Microsoft.VC++2015-2022Redist-x64

Other version ids:
- Microsoft.VC++2015-2022Redist-x86
- Microsoft.VC++2019Redist-arm64
To Top