LoopRun Barcelona 2020

インストール手順

この » PECL 拡張 モジュールは PHP にバンドルされていません。

Ubuntu 18.04 上の PHP 7.2 でインストールする例:

// 依存するものをインストール
$ apt install build-essential libprotobuf-dev libboost-dev openssl protobuf-compiler

// 望ましい拡張機能と一緒にPHPをインストール; php7.2-dev はコンパイルに必須
$ apt install php7.2-cli php7.2-dev php7.2-mysql php7.2-pdo php7.2-xml

// 拡張機能をコンパイル
$ pecl install mysql_xdevapi

pecl install コマンドは、PHP の拡張機能を有効にしません(デフォルト) し、PHP の拡張機能を有効にする方法は複数あります。 Ubuntu 18.04 上の PHP 7.2 でインストールする別の例を以下に示します:

// 自分の ini ファイルを作る
$ echo "extension=mysql_xdevapi.so" > /etc/php/7.2/mods-available/mysql_xdevapi.ini

// 'phpenmod' コマンドを使う (注意: Debian/Ubuntu 特有のコマンドです)
$ phpenmod -v 7.2 -s ALL mysql_xdevapi

// 'phpenmod' の代わりに、手動でシンボリックリンクを張る
// $ ln -s /etc/php/7.2/mods-available/mysql_xdevapi.ini /etc/php/7.2/cli/conf.d/20-mysql_xdevapi.ini

// MySQL 拡張機能が有効になっているかどうかをチェックしよう
$ php -m |grep mysql

mysql_xdevapi
mysqli
mysqlnd
pdo_mysql

この PECL 拡張モジュールをインストールする方法は、 マニュアルの PECL 拡張モジュールのインストール という章にあります。 新規リリース・ダウンロード・ソースファイル・管理者情報・CHANGELOG といった関連する情報については、次の場所にあります。 » https://pecl.php.net/package/mysql_xdevapi.

add a note add a note

User Contributed Notes

There are no user contributed notes for this page.
To Top