SunshinePHP 2020 CFP Started

要件

» OpenSSL および » libssh2 ライブラリは必須です。 開発用のライブラリがインストールされていることを確認しておきましょう。 おそらく openssl-dev のような名前のパッケージになっているでしょう。

libssh2 ライブラリのバージョン 1.2 以降が必須となります。しかし、 pecl/ssh2 の新しいリリースでは、より新しいバージョンを要求することになるかもしれません (リリースノートを参照ください)。

ssh2_auth_agent() 関数を使うには、 libssh >= 1.2.3 が必要です。

チャネルストリームで stream_set_timeout() に対応するには、 libssh >= 1.2.9 が必要です。

libssh2 には二種類の形式があります。gcrypt を使ったものと openssl を使ったものです。 libssh2 のビルドに gcrypt ライブラリを使っている Linux ディストリビューションもあれば、 そうではなく openssl を使っているものもあります。 libssh2 を gcrypt でコンパイルしたときにはいくつかの問題が発生するので、openssl を使いましょう。

add a note add a note

User Contributed Notes

There are no user contributed notes for this page.
To Top