International PHP Conference Berlin 2021

Requirements

As of version 1.8.0, the driver requires PHP 7.0 or higher. Previous versions of the driver allow compatibility with older PHP versions.

The driver requires » libbson and » libmongoc, and will use bundled versions of both libraries by default. System libraries may also be used, as discussed in the manual installation documentation.

The driver, via libmongoc, optionally depends on a TLS library (e.g. OpenSSL) and will use it if available. If the build process fails to find a TLS library, users should check that the appropriate development package (e.g. libssl-dev) and » pkg-config are both installed. The process for detecting and configuring TLS libraries is discussed in more detail in the manual installation documentation.

» Cyrus SASL is an optional dependency to support Kerberos authentication and will be used if available.

Note: Due to potential problems representing 64-bit integers on 32-bit platforms, users are advised to use 64-bit environments. When using a 32-bit platform, be aware that any 64-bit integer read from the database will be returned as a MongoDB\BSON\Int64 instance instead of a PHP integer type.

add a note add a note

User Contributed Notes 1 note

up
-16
mfoley at cms-controls dot com
3 years ago
I ran into this module requiring libsasl.dll available in the Windows Path. I thought that was just for the old driver, but apparently not. I'm running PHP 7.0.7 with Apache 2.4 (VC14), x64 thread-safe. I was working with version 1.2.5 of the MongoDB driver.
To Top