PHP 7.4.0beta4 released!

Pré-requis

Pour que ces fonctions soient disponibles, vous devez compiler PHP avec le support de l'extension mysqli.

MySQL 8

Si PHP est utilisé antérieur à sa version 7.1.16, ou PHP 7.2 antérieur à 7.2.4, le plugin de mot de passe doit être définit à mysql_native_password pour MySQL 8 Server car sinon des erreurs similaire à The server requested authentication method unknown to the client [caching_sha2_password] peuvent apparaitre même si caching_sha2_password n'est pas utilisé.

Ceci est due au fait que MySQL 8 utilise par défaut caching_sha2_password, un plugin qui n'est pas reconnu par les anciennes versions de PHP (mysqlnd). À la place il faut modifier le paramètre default_authentication_plugin=mysql_native_password dans my.cnf. Le plugin caching_sha2_password sera surporté dans une version future de PHP. En attendant, l'extension mysql_xdevapi le supporte.

add a note add a note

User Contributed Notes 1 note

up
-10
alvaro at demogracia dot com
1 year ago
Supported authentication methods are listed in the "Loaded plugins" row of the "mysqlnd" section in phpinfo(). Look for plugins that start with "auth_plugin_…".
To Top