PHP 8.0.0 Released!

Installation

Linux systems

Von PHP 7.4.0 an muss, um diese Funktionen nutzen zu können, PHP mit der Option --with-zip kompiliert werden. Zuvor musste Zip-Unterstützung durch Verwendung der --enable-zip Konfigurationsoption aktiviert werden.

Mit PHP 5.6.0 wurde die --with-libzip=DIR Konfigurationsoption hinzugefügt, um eine System-Installation von libzip zu verwenden. libzip 0.11 wird benötigt, aber 0.11.2 oder höher werden empfohlen.

Von PHP 7.3.0 an wird die Kompilierung mit der gebündelten libzip nicht mehr empfohlen, ist aber noch immer möglich, indem --without-libzip zur Konfiguration hinzugefügt wird. Von PHP 7.4.0 an ist die gebündelte libzip nicht mehr vorhanden.

Windows

Ab PHP 5.3 ist diese Erweiterung eingebaut. Vorher mussten Windows Benutzer php_zip.dll in ihrer php.ini laden um diese Funktionen nutzen zu können.

Installation via PECL

Information zur Installation dieser PECL-Extension finden sie im Kapitel Installation von PECL-Extensions. Zusätzliche Informationen wie neue Releases, Downloads, Quelldateien, Maintainerinformation und ein CHANGELOG finden Sie hier: » https://pecl.php.net/package/zip.

add a note add a note

User Contributed Notes 5 notes

up
3
Anonymous
4 months ago
This is how I installed it on my machine (ubuntu):
php 7:

sudo apt-get install php7.0-zip

service apache2 restart
up
7
Marcel
1 year ago
Getting error

  configure: error: Please reinstall the libzip distribution

when compiling this extension for php 7.3?

You need to install the 'libzip' package.

In Dockerfile you would do this like:

# Install zip
RUN apt-get update && \
     apt-get install -y \
         libzip-dev \
         && docker-php-ext-install zip
up
0
php dot net at cage dot is
5 months ago
For those of you asking about how to update this within your Dockerfile, the answer seems to be to add to the environment variable like so:

ENV PHP_EXTRA_CONFIGURE_ARGS="--with-apxs2 --disable-cgi --with-zip"
up
-1
sgalyen at notspamarizona dot edu
7 months ago
In trying to compile PHP 7.4.x on CentOS 7.x I'm running into the dreaded "Package requirements (libzip >= 0.11) were not met"

As the referenced RPM package for lipzip 0.11.2 is a 3rd party (repo named Psychotic Ninja Plus, doesn't exactly inspire faith) I tried to compile from source. 

I was able to find the git sha1 for 0.11.1 and compile successfully - if anyone needs it:
d2aac947ccc85bd4abbd02a6d9b237bdaa89d3f0

If someone in the know could post the sha1 for 0.11.2, or whatever preferred version of libzip that successfully compiles, I would appreciate it!
up
-11
mattcasiro at gmail dot com
2 years ago
If installing this in a Docker image using:
"docker-php-ext-install zip"

you may get an error such as:
"docker-php-ext-install zip returned a non-zero code: 1"
or
"zip support requires ZLIB"

Docker documentation now suggests this as the proper way to install, to ensure the dependant libraries are installed with it:
# Install zip
RUN apt-get update && \
     apt-get install -y \
         zlib1g-dev \
         && docker-php-ext-install zip
To Top