PHP 8.1.0 Released!

pspell_config_repl

(PHP 4 >= 4.0.2, PHP 5, PHP 7, PHP 8)

pspell_config_replChoisit le fichier qui contient les paires de remplacement

Description

pspell_config_repl(PSpell\Config $config, string $filename): bool

Choisit le fichier qui contient les paires de remplacement.

Les paires de remplacement améliorent la qualité du vérificateur. Lorsqu'un mot est mal orthographié et qu'aucune suggestion valable n'est trouvée dans le dictionnaire, pspell_store_replacement() sera utilisée pour enregistrer une paire de remplacement et pspell_save_wordlist() pour sauver le dictionnaire avec les paires de remplacement.

pspell_config_repl() doit être utilisé avec une configuration avant d'appeler pspell_new_config().

Liste de paramètres

config

Une instance de PSpell\Config.

filename

Le fichier doit être accessible en écriture pour l'utilisateur invoquant PHP (ex. nobody).

Valeurs de retour

Cette fonction retourne true en cas de succès ou false si une erreur survient.

Historique

Version Description
8.1.0 Le paramètre config attend désormais une instance de PSpell\Config ; auparavant, une ressource était expected.

Exemples

Exemple #1 pspell_config_repl()

<?php
$pspell_config 
pspell_config_create("en");
pspell_config_personal($pspell_config"/var/dictionaries/custom.pws");
pspell_config_repl($pspell_config"/var/dictionaries/custom.repl");
$pspell pspell_new_config($pspell_config);
pspell_check($pspell"thecat");
?>

Notes

Note:

Cette fonction ne marchera qu'avec pspell .11.2 et aspell .32.5 ou ultérieurs.

add a note add a note

User Contributed Notes

There are no user contributed notes for this page.
To Top