PHP 7.1.x で推奨されなくなる機能

ext/mcrypt

mcrypt 拡張モジュールは十年近くにわたって放置されており、極めて使いづらいものです。 そこで、この拡張モジュールを非推奨にしました。かわりに OpenSSL を使いましょう。 mcryptは PHP 7.2 でコアから削除されて、PECL に移る予定です。

mb_ereg_replace()mb_eregi_replace() の eval オプション

mb_ereg_replace()mb_eregi_replace() で、 パターン修飾子 e が非推奨となりました。

add a note add a note

User Contributed Notes 1 note

up
0
Petro Shpyhotskyi
7 days ago
Extention mcrypt is deprecated in 7.1 and removed in 7.2.
To Top