PHP 8.2.0 Alpha 2 available for testing

Kurulum

GD desteğini etkin kılmak için PHP --with-gd[=DiZiN] seçeneği ile derlenmelidir; buradaki DiZiN GD'nin kurulu olduğu dizindir. GD kütüphanesinin PHP ile dağıtılan sürümünü kullanmak için PHP --with-gd seçeneğiyle derlenmelidir. GD kütüphanesi libpng ve libjpeg desteğini gerektirir. PHP 7.4.0'dan itibaren --with-gd seçeneği, --enable-gd (eklenti etkinleştirilecekse) ve --with-external-gd (paketlenmiş olan yerine harici bir libgd kullanmayı tercih etmek için) haline gelir.

Windows'ta, GD DLL php_gd.dll dosyası php.ini dosyasında bir eklenti olarak belirtilmelidir. PHP 8.0.0 öncesinde DLL ismi php_gd2.dll idi.

GD'nin yetenekleri daha fazla görüntü biçemi kullanmak üzere genişletilmek istenirse PHP'yi derlemek için yapılandırırken --with-XXXX seçenekleri kullanılmalıdır.

Desteklenen görüntü biçemleri
Görüntü Biçemi Yapılandırma Anahtarı
jpeg Jpeg desteğini etkinleştirmek için --with-jpeg-dir=DiZiN seçeneği kullanılır. Jpeg 6b, 7 veya 8 desteklenir. PHP 7.4.0 ve sonrasında bu seçenek yerine --with-jpeg seçeneği kullanılır.
png PNG desteğini etkinleştirmek için --with-png-dir=DiZiN seçeneği kullanılır. libpng zlib kütüphanesini gerektirdiğinden --with-zlib-dir[=DiZiN] seçeneği de gerekecektir. PHP 7.4.0 ve sonrasında --with-png-dir ve --with-zlib-dir seçenekleri kaldırılmış olup libpng ve zlib gerekmektedir.
xpm XPM desteğini etkinleştirmek için --with-xpm-dir=DiZiN seçeneği kullanılır. Eğer yapılandırma betiği kütüphanelerinizin yerini bulamazsa X11 kütüphanelerinin kurulu olduğu yol belirtilmelidir. PHP 7.4.0 ve sonrasında bunun yerine --with-xpm kullanılmaktadır.
webp Webp desteğini etkinleştirmek için --with-webp-dir=DiZiN seçeneği kullanılır. PHP 7.4.0 ve sonrasında bunun yerine --with-webp kullanılmaktadır.

Bilginize: PHP'yi libpng desteği ile derlerken, libpng ile ilintili GD sürümü kullanılmalıdır.

GD'nin yeteneklerini farklı yazıtiplerini kullanacak şekilde genişletmek için kurulum sırasında bunu --with-XXXX yapılandırma seçeneği ile belirtmek gerekir.

Desteklenen yazıtipi kütüphaneleri
Yazıtipi Kütüphanesi Yapılandırma Seçeneği
FreeType 2 FreeType 2 desteğini etkinleştirmek için --with-freetype-dir=DiZiN seçeneği kullanılır. PHP 7.4.0 ve sonrasında bunun yerine kütüphaneyi pkg-config ile bulan --with-freetype seçeneği kullanılmaktadır.
Doğal TrueType dizge işlevi Doğal TrueType dizge işlevi desteğini etkinleştirmek için --enable-gd-native-ttf seçeneği kullanılır. (Bu seçenek etkisiz olup PHP 7.2.0 ve sonrasında kaldırılmıştır.)

add a note add a note

User Contributed Notes 22 notes

up
22
Anonymous
5 years ago
For all who use php 7 and ubuntu

sudo apt-get install php7.0-gd
up
19
james dot a dot munsch at gmail dot com
7 years ago
sudo apt-get install php5-gd && sudo service apache2 restart

To install under Ubuntu 14.04.
up
2
Mike K
6 years ago
On Ubuntu I was missing the libpng-dev, libjpeg-dev (and in my case) libwebp-dev libraries, all gettable with apt-get.

Also once those libraries are installed, including --with-png-dir --with-jpeg-dir --with-webp-dir, without any values (i.e. =/dir) appeared to be valid ... though admittedly I didn't try without (in case the configure script autodetected them).
up
2
fabrizzio at webtux dot cl
3 years ago
php --version if result is 7.2 version

sudo apt-get install php7.2-gd
up
1
florian
10 years ago
People having difficulties setting the --with-libdir option needs to set it like this :

--with-libdir=lib64

That option works fine. Doing --with-libdir=/usr/lib64 doesn't work because the configure script prepends the --prefix option before the --with-libdir option. So, doing --with-libdir=/usr/lib64 makes the configure script to look for libs in /usr/usr/lib64, which is wrong of course, and not in /usr/lib64.
up
0
abdulbasitsaeed
3 years ago
To install PHP GD extension on an Amazon Linux AMI server, with php 7:

sudo yum install php 70-gd

Do remember to restart Apache after the installation!

sudo service httpd restart
up
0
Qussayyon Qamaron: Qusai.zf2@gmailcom
5 years ago
#install under Ubuntu 16.04:
    * if you have access to PHP7.1:
        <sudo> apt install php7.1-gd && <sudo> systemctl restart apache2
    * if you have access to PHP7.0:
        <sudo> apt install php7.0-gd && <sudo> systemctl restart apache2

------------------------------------------------
Qussayyon Qamaron: Qusai.zf2gmailcom
up
1
msc at homofaber dot com
13 years ago
It should be noted that it might be pretty easy to install gd without the need to recompile php, when using debian:

apt-get install php5-gd
up
0
Joseph Marlin
11 years ago
I also had to install the libgd package in addition to php5-gd:

sudo apt-get install libgd2-xpm-dev*
up
-1
boly38 at gmail dot com
11 years ago
To get GD bundled under Ubuntu, the way to recompile php5 with gd is described here (french) http://doc.ubuntu-fr.org/modules_php#php5-gd
up
-1
Parmjit Singh
1 year ago
Installation on Pop-os No need for php5 or php7.0 etc:

sudo apt install php-gd
up
-3
tecknovice at gmail dot com
2 years ago
currently is php7.2-gd

sudo apt install php7.2-gd
up
-2
octopus at logicaloctopus dot com
11 years ago
I was running PHP on a SUSE box on amazon EC2.
to get gd to work all I had to do was to run:
> yast -i php5_gd

and when that completed I just restarted apache. voila!
up
-2
leyluj21 at gmail dot com
7 years ago
If you are using PHPBREW , the extension is called gd.
So you do.
```
phpbrew ext install gd
```

It will compile the extension to the core.
up
-4
elassoto at hotmail dot com
11 years ago
If you have already compiled PHP and want to recompile '--with-gd', don't forget to run 'make clean' first!
up
-6
alejo dot jm at gmail dot com
9 years ago
On Macox lion with mac port just use:
sudo port install php5-gd
up
-8
nordin74
2 years ago
Since 7.4 replace "--with-gd" by "--enable-gd"
up
-10
Gabriel Torres
2 years ago
As of PHP 7.4, to enable GD you have to use --enable-gd instead of --with-gd
up
-5
remalsha at gmail dot com
4 years ago
On AntergosOS ( Arch linux )

*first run >>php -v   and get current php version. In my case for PHP 7.1.14

      sudo pacman -S php71-gd  

then restart you apache server using,
    
      sudo systemctl restart httpd
up
-15
theonestep4 at gmail dot com
5 years ago
To install on CentOS:

yum install php-gd
up
-5
omni at ominsapien dot com
1 year ago
Hello. Does GD image processing allow for color spaces / color profiles to be defined or maintained from the source image? For example, if I upload a jpg with ProPhoto RGB color space with the embedded profile, will all of the subsequent processed images that are output maintain the profile? Or is there no profile and or is it changed to sRGB?

Same question goes for ImageMagick.

Thank you so much!
To Top